Cómo usar la función SUMAR.SI.CONJUNTO de Excel

La función SUMAR.SI.CONJUNTO de Excel es muy parecida a SUMAR.SI, pero con la gran diferencia de que en esta podemos añadir hasta 127 criterios para que se realice esta suma.

Por eso, en este post te contamos qué es y cómo funciona esta función, cuál es su sintaxis y un ejemplo súper claro de cómo podemos utilizarla.

¡Sigue leyendo para saber cómo!

¿Qué es la función SUMAR.SI.CONJUNTO?

La función SUMAR.SI.CONJUNTO de Excel es una de las más interesantes, ya que nos permite sumar los valores contenidos en un rango de celdas que cumplan las condiciones que nosotros especificamos en la función.

La diferencia que encontramos con la función SUMAR.SI es que esta solo permite un criterio, mientras que SUMAR.SI.CONJUNTO permite muchos (hasta 127) y, por tanto, las búsquedas que podemos realizar son súper exhaustivas.

Si quieres conocer un poco más la función de SUMAR.SI de Excel, te dejo este post en que el profundizamos mucho más sobre ella.

portada sumarsi excel Cómo usar la función SUMAR.SI de Excel

En este post analizamos la función SUMAR.SI de Excel: cómo utilizarla, cuál es su sintaxis y algunos ejemplos prácticos.

¿Cómo usar la función SUMAR.SI.CONJUNTO en Excel?

La función SUMAR.SI.CONJUNTO tiene una sintaxis muy sencilla, en la que tendremos, por una parte, el rango de celdas donde están los datos que estamos interesados en sumar, y por otro lado los criterios que queremos que cumplan.

La sintaxis es:

  • Rango_suma: el rango de celdas donde están los datos que queremos sumar.
  • Rango_criterios1: el rango de celdas donde la función evaluará el criterio 1 (que es el tercer argumento)
  • Criterio1: el criterio que deben cumplir las celdas que hemos definido en el segundo argumento de “Rango_criterio1”.
  • Rango_criterios2: el rango de celdas donde la función evaluará el criterio 2.
  • Criterio2: el criterio que deben cumplir las celdas que hemos definido en el segundo argumento de “Rango_criterio2”.

De esta manera los valores que contengan las celdas que hemos especificado en el primer argumento (Rango_Suma) solo se sumarán si se cumplen todos los criterios que hemos indicado después.

Podemos añadir sucesivos criterios según las condiciones que queramos añadir.

Ejemplos de cómo usar SUMAR.SI.CONJUNTO en Excel

En este apartado veremos varios ejemplos de cómo usar la función SUMAR.SI.CONJUNTO de Excel en diferentes situaciones.

Usar SUMAR.SI.CONJUNTO con dos condiciones

Por ejemplo, podríamos usar SUMAR.SI.CONJUNTO de Excel si somos una tienda de gominolas y tenemos un Excel con nuestro inventario y queremos saber cuántos regalices rojos hemos vendido.

El Excel sería así, con un listado de las gominolas en una columna y sus especificaciones en la otra:

En este caso, solo queremos sumar las cantidades de los regalices rojos (no queremos saber ningún otro tipo de chuchería ni los regalices negros), por lo que usaremos la función SUMAR.SI.CONJUNTO para escoger los que queremos.

En este caso, la fórmula sería así:

=SUMAR.SI.CONJUNTO(C2:C6;A2:A6;”Regalices”;B2:B6;”Rojos”)

  • Como primer argumento el rango donde están los valores de las ventas.
  • Como segundo argumento el primer rango de criterios, en este caso es “A2:A6” y como tercer argumento el criterio de “Regalices”.
  • Como cuarto argumento el segundo rango de criterio, “B2:B6” y como quinto argumento el criterio de “Rojos”.
sumar si conjunto condiciones
En este ejemplo aplicamos la función de SUMAR.SI.CONJUNTO de Excel.

Y como resultado obtendríamos la suma de los regalices rojos.

total sumarsiconjunto condiciones
Este es el resultado.

SUMAR.SI.CONJUNTO con criterio de fecha mes en Excel

En este caso vamos a ver como utilizar la función SUMAR.SI.CONJUNTO de Excel si queremos sumar un o unos valores asociados a determinadas fechas.

Por ejemplo, en este Excel tenemos un listado del importe cobrado a un cliente por fechas.

Ha fallado el sistema y las fechas están desordenadas y nosotros queremos calcular el total cobrado en el año 2022.

sumar.si.conjunto
Estos son los datos de nuestro ejemplo.

Para eso, vamos a introducir la fecha del 1 de enero de 2022 en la celda D2.

sumar.si.conjunto excel
Añade la fecha de inicio del año sobre el que vamos a operar.

Ahora, en la celda donde queremos ver el total calculado vamos a introducir la siguiente fórmula:

=SUMAR.SI.CONJUNTO(B2:B12;A2:A12;”>=”&D2;A2:A12;”<=”&FIN.MES(D2;0))

No te preocupes, porque, aunque sea una fórmula larga vamos a ir desgranándola argumento a argumento.

  • Primer argumento: (B2:B12) el rango de valores que queremos sumar.
  • Segundo argumento: (A2:A12) las fechas correspondientes a los valores que queremos sumar, como rango de criterio 1.
  • Tercer argumento: (“>=”&D2) aquí tenemos dos criterios unidos por el signo de “&” en el que indicamos que la fecha sea mayor o igual a la que hemos indicado en la casilla D2 (1 de enero del 2022).
  • Cuarto argumento: (A2:A12) donde indicamos de nuevo las fechas, siendo el rango de criterio 2
  • Quinto argumento: (<=”&FIN.MES(D2;0)) donde indicamos el criterio 2. Estamos indicando que las fechas deben ser menores o iguales a el número de serie del último día del mes que hemos indicado en D2.
sumar siconjunto excel
Aquí podemos ver cómo aplicamos la fórmula de SUMAR.SI.CONJUNTO con fechas.

Cuando haces clic en “Enter” aparece el resultado con la suma del importe correspondiente a las fechas del año 2022.

total sumar si conjunto excel
Aquí podemos ver el resultado de aplicar la función SUMAR.SI.CONJUNTO
¿Te gustaría leer más sobre esta temática? Busca aquí:

Acerca del autor: Lucía Berlanga

Soy colaboradora de este blog. Me he formado en el tratamiento de datos, desde su extracción, al análisis y visualización, y disfruto mucho con el desarrollo web.

He trabajado en diferentes sectores, pero desde hace un tiempo enfocada a diseño y desarrollo web, junto al marketing digital. Por eso, en este blog hablaremos mucho sobre tecnología y SEO, entre otras muchas cosas :)